Results 1 to 2 of 2

Thread: Pulsing front brakes. Help me solve this!

  1. #1
    Senior Member
    Join Date
    Jan 2011
    Location
    Austin
    Status
    Expert
    Bike #
    98
    Posts
    2,078

    Pulsing front brakes. Help me solve this!

    I bought Sean Gurevich's 2009 ZX6R for cheap, but I'm approaching my limit of its value as I fix problems like wiring, botched bearing installs and missing parts. The last thing I need to work out is major pulsing on the brakes. I don't think the wheels themselves are the problem because the vibration doesn't occur (or isn't noticeable) at speed while NOT on the brakes.

    I've installed new steering stem bearings, swapped brake discs and wheels, serviced brake calipers (new pad retaining pins, cleaned pistons, new pads), installed new rubber. The bike rides better (it previously vibrated bad merely at speed without brakes but no longer) but the issue under braking persists. When I changed pads, I sanded the rotors to break the glaze. I ordered from eBay a wheel that is "guaranteed straight"; this is the wheel I used for two sprints in Houston, but pulsing was just as bad and did not inspire confidence. Wheel bearings seem okay, and Sean claimed to replace bearings on each wheel he bought; my observation of the botched installation of the steering stem bearing could be telling.

    I have a dial indicator and just purchased a balancing/truing stand, so I began taking measurements. Things I've measured:
    - wheel rim (vertical [y-axis] and horizontal [x-axis])
    - wheel hoop (hoop being the part closest to the spokes and valve stem)
    - wheel hub (between the spokes and the brake rotor mounting face)
    - axle hub (basically, the part in which the bearing mounts, which is about 2" diameter)
    - brake disc

    Because the vibration doesn't occur without braking, I'm not especially concerned with wheel rim and wheel hoop, even though they may have .030" runout (maybe more). I've noticed the vertical runout on the hub sections to be .030" on one side and maybe .010" on the other for the same wheel; this kinda provides an egg shape instead of a circle. With my naked eye and no gauge, I can also see the brake disc move up and down (perhaps mimicking the hub runout), which is the most bizarre thing I've seen that could be contributing to this (petal-type discs make measuring this more difficult). I don't know how the wheel could even get damaged in this way. I haven't measured to see if the hub is actually shaped this way or if the bearings are causing this movement.

    One other thing is none of the many brake discs I have for this bike appear to "float." I can't find anything definitive indicating if they should move/float or not.

    Thoughts? Help me have no excuses for poor performance!
    Provisional Expert #98

  2. #2
    Senior Member
    Join Date
    Apr 2013
    Location
    Dallas
    Status
    Expert
    Bike #
    64
    Posts
    502
    Sounds like you need new rotors. Every time i've experienced pulsing on the brakes it was a bent/warped rotor. Have you tried known good rotors? This up and down movement of the rotor does not seem right.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •